5.2.3 Проверка на конфликты

Используйте опцию --conflicts для проверки наличия конфликтов с указанным пакетом. Базовый синтаксис:

rpm –q query_options --conflicts packages

Например:

# rpm -q --conflicts httpd

thttpd

Вывод этой команды говорит нам о том, что пакет httpd (веб-сервер Apache) конфликтует с пакетом thttpd. Оба пакета предоставляют сходные возможности. Пакеты httpd и thttpd вследствии этого не могут быть установлены в систему одновременно. Эта информация содержится в пакете httpd, имеющем запись, указывающую на возможный конфликт. При этом конфликт не гарантируется. Возможно, что работоспособность пакетов, установленных вместе, не пострадает. Но производитель пакета httpd предупреждает о возможных проблемах, а пакет опубликовывает эту информацию для общего сведения.

Система RPM будет сообщать о конфликтах и выводить ошибку, если администратор попытается установить конфликтующие пакеты. Этот механизм дает создателям пакетов реальную возможность предупредить пользователей о возможных проблемах и передать ответственность за возможные ошибки времени выполнения администратору системы.

Опции форсирования установки позволяют обойти ошибки на страх и риск администратора.

Далее - Какой пакет требует данную возможность?
Назад - Проверка зависимостей вида Provides
Содержание